建议和反馈

请填写你的反馈内容

问答 > 共识算法 > 问答详情
求助中

部署本地区块链技术时出错10LK

当我尝试在本地部署我的nodejs应用程序(区块链)时,遇到以下错误。

npm ERR! Linux 4.4.0-31-genericnpm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "install" "--quiet"npm ERR! node v4.7.2npm ERR! npm  v4.1.1npm ERR! code ELIFECYCLEnpm ERR! hashtable@2.0.2 install: `node-gyp configure build`npm ERR! Exit status 1npm ERR! npm ERR! Failed at the hashtable@2.0.2 install script 'node-gyp configure build'.npm ERR! Make sure you have the latest version of node.js and npm installed.npm ERR! If you do, this is most likely a problem with the hashtable package,npm ERR! not with npm itself.npm ERR! Tell the author that this fails on your system:npm ERR!     node-gyp configure buildnpm ERR! You can get information on how to open an issue for this project with:npm ERR!     npm bugs hashtablenpm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls hashtable
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!     /usr/src/app/npm-debug.log
ERROR: Service 'asset-diamond-demo' failed to build: The command '/bin/sh -c npm install --quiet' returned a non-zero code: 1

但是,当我从家里的个人笔记本电脑部署它时,它就被部署了。似乎不在办公室里。

有人可以提出任何解决方案吗?


2020-12-07
0
请先登陆或注册

彩手导导2020-12-07

重新编写,注意对齐

投一票
评论(0)
赞赏(0)
鹿han2020-12-07

安装nvm并使用它来确保您具有干净,最新的工作节点设置。尝试使用nvm而不是4安装Node 7.something。

投一票
评论(0)
赞赏(0)
邀请

感谢您的善举,每一次解答会成为新人的灯塔,回答被采纳后获得20算力和相应的LK币奖励